System Requirements FAQ

What do I need to access eVetPractice?

To access your eVetPractice, all you need is internet access* and one of the following browsers:

Chrome - We support the current version and one version previous

Firefox - We support the current version and one version previous

Safari for iOS - released within the last 2 years

Safari for macOS - released within the last 2 years

Edge - We support the current version and one version previous
The new version of Edge can be downloaded HERE

*We recommend a minimum download speed of 30 Mbps to avoid slowness or unresponsiveness of eVetPractice.

What should I do if my browser is outdated?

We recommend that you keep your browser up to date to receive the latest enhancements and security updates from your browser. If you are accessing eVet from an unsupported browser or version, you may not be able to use all features of eVetPractice and some areas may behave in unexpected ways.

How do I keep my browser up to date?

Please refer to the support site of your browser for instruction on how to get the latest version installed. Chrome, Edge, and Firefox all 

I have Windows XP and can't upgrade my browser. Can I still use eVet with the version of the browser I have?

With unsupported browsers, you may have trouble viewing some areas of eVet and may not be able to perform all eVet functionalities.

We highly recommend our users to transition from Windows XP as Microsoft has stopped supporting this operating system. To understand the risk of using Window XP, please review Microsoft document link here - https://support.microsoft.com/en-us/help/14223/windows-xp-end-of-support

Have more questions? Submit a request

Comments